summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorFernando Nasser <fnasser@redhat.com>2000-12-11 21:11:16 +0000
committerFernando Nasser <fnasser@redhat.com>2000-12-11 21:11:16 +0000
commitdc75b43407356632ae65e16ee87f3e9fce250199 (patch)
tree22c7caec46c8dcaa310af33aa33e7cb945ce7977 /gdb/configure.in
parent6f6fbb98146e65a2e04fbaaa17d0b929a306b3ba (diff)
downloadgdb-dc75b43407356632ae65e16ee87f3e9fce250199.tar.gz
2000-12-11 Fernando Nasser <fnasser@redhat.com>
* Makefile.in (SUBDIR_GDBTK_OBS, SUBDIR_GDBTK_SRCS, SUBDIR_GDBTK_DEPS, SUBDIR_GDBTK_INITS, SUBDIR_GDBTK_LDFLAGS, SUBDIR_GDBTK_CFLAGS): New macros. For gdbtk subdir. * configure.in: Fix typo. It is CONFIG_OBS not CONFIG_OJS. Use the SUBDIR_GDBTK_* macros instead of hard coded file names. * configure: Regenerate.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in13
1 files changed, 7 insertions, 6 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 08c78ff4782..efe04cdf752 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -407,7 +407,7 @@ if test ${build} = ${host} -a ${host} = ${target} ; then
if test "$GCC" = "yes" ; then
AC_MSG_RESULT(yes)
AC_DEFINE(HAVE_HPUX_THREAD_SUPPORT)
- CONFIG_OBS="${CONFIG_OJS} hpux-thread.o"
+ CONFIG_OBS="${CONFIG_OBS} hpux-thread.o"
CONFIG_SRCS="${CONFIG_SRCS} hpux-thread.c"
else
AC_MSG_RESULT(no (suppressed because you are not using GCC))
@@ -873,7 +873,7 @@ if test "${enable_gdbtk}" = "yes"; then
TIX_DEPS="${TIX_BUILD_LOCATION}/${TIX_LIB_FILE}"
fi
- ENABLE_CFLAGS="$ENABLE_CFLAGS -DGDBTK"
+ ENABLE_CFLAGS="${ENABLE_CFLAGS} \$(SUBDIR_GDBTK_CFLAGS)"
# Tcl/Tk 8.1 require -fwritable strings. I don't
# know whether 8.2 will or not, but I bet it will.
# I don't have to worry about 7.x since we don't support it.
@@ -886,16 +886,17 @@ if test "${enable_gdbtk}" = "yes"; then
# Include some libraries that Tcl and Tk want.
TCL_LIBS='$(LIBGUI) $(ITCL) $(ITK) $(TIX) $(TK) $(TCL) $(X11_LDFLAGS) $(X11_LIBS)'
- CONFIG_DEPS='$(LIBGUI) $(ITCL_DEPS) $(ITK_DEPS) $(TIX_DEPS) $(TK_DEPS) $(TCL_DEPS)'
# Yes, the ordering seems wrong here. But it isn't.
# TK_LIBS is the list of libraries that need to be linked
# after Tcl/Tk. Note that this isn't put into LIBS. If it
# were in LIBS then any link tests after this point would
# try to include things like `$(LIBGUI)', which wouldn't work.
GDBTKLIBS="${TCL_LIBS} ${TK_LIBS}"
- CONFIG_SRCS="${CONFIG_SRCS} gdbtk/generic/gdbtk.c gdbtk/generic/gdbtk-cmds.c gdbtk/generic/gdbtk-hooks.c gdbtk/generic/gdbtk-varobj.c gdbtk/generic/gdbtk-wrapper.c"
- CONFIG_OBS="${CONFIG_OBS} gdbtk.o gdbtk-cmds.o gdbtk-hooks.o gdbtk-varobj.o gdbtk-wrapper.o"
- CONFIG_INITS="${CONFIG_INITS} gdbtk/generic/gdbtk.c gdbtk/generic/gdbtk-cmds.c gdbtk/generic/gdbtk-hooks.c gdbtk/generic/gdbtk-varobj.c gdbtk/generic/gdbtk-wrapper.c"
+
+ CONFIG_OBS="${CONFIG_OBS} \$(SUBDIR_GDBTK_OBS)"
+ CONFIG_DEPS="${CONFIG_DEPS} \$(SUBDIR_GDBTK_DEPS)"
+ CONFIG_SRCS="${CONFIG_SRCS} \$(SUBDIR_GDBTK_SRCS)"
+ CONFIG_INITS="${CONFIG_INITS} \$(SUBDIR_GDBTK_INITS)"
CONFIG_ALL="${CONFIG_ALL} \$(SUBDIR_GDBTK_ALL)"
CONFIG_CLEAN="${CONFIG_CLEAN} \$(SUBDIR_GDBTK_CLEAN)"
CONFIG_INSTALL="${CONFIG_INSTALL} \$(SUBDIR_GDBTK_INSTALL)"