summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorAndrew Cagney <cagney@redhat.com>2000-06-12 06:09:06 +0000
committerAndrew Cagney <cagney@redhat.com>2000-06-12 06:09:06 +0000
commitf4db4067c8bf58a85ffbc0d89483e3d3425f923e (patch)
tree14cdebf8108c4352bb5f7fd3889d12508cd282de /gdb/configure.in
parent963174cbc7fe7802213f74f7b6fbe5239e004655 (diff)
downloadgdb-f4db4067c8bf58a85ffbc0d89483e3d3425f923e.tar.gz
Set SER_HARDWIRE using autoconf instead of via XDEPFILES. Include
ser-tcp.o by default.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 958ff9c8a53..df543083361 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -626,6 +626,15 @@ AC_CACHE_CHECK([for cygwin], gdb_cv_os_cygwin,
lose
#endif],[gdb_cv_os_cygwin=yes],[gdb_cv_os_cygwin=no])])
+
+dnl Figure out which of the many generic ser-*.c files the _host_ supports.
+SER_HARDWIRE="ser-unix.o ser-pipe.o ser-tcp.o"
+case ${host} in
+ go32*-*-* ) SER_HARDWIRE=ser-go32.o ;;
+esac
+AC_SUBST(SER_HARDWIRE)
+
+
dnl Figure out which term library to use.
if test x$gdb_host = xgo32; then
TERM_LIB=