summaryrefslogtreecommitdiff
path: root/gdb/gdbtk/plugins/configure.in
diff options
context:
space:
mode:
authorJim Blandy <jimb@codesourcery.com>2003-05-13 00:08:58 +0000
committerJim Blandy <jimb@codesourcery.com>2003-05-13 00:08:58 +0000
commitad20141640f390ddb988537bf7d93316e5388e4b (patch)
treec1645477648a946f3973c701fb89b76e295e5bcc /gdb/gdbtk/plugins/configure.in
parentea1c83e1893b74392032336333d19c00a414611d (diff)
downloadgdb-jimb-ppc64-linux-20030509-branch.tar.gz
Patch from Will Schmidt <willschm@us.ibm.com>:jimb-ppc64-linux-20030509-branchcvs/jimb-ppc64-linux-20030509-branch
These changes enable support of PPC64 architecture. * config/powerpc/ppc64linux.mh: New file. * config/powerpc/ppc64linux.mt: New file. * config/powerpc/tm-ppc64linux.h: New file. * ppc64-linux-tdep.c: New file. * configure.host: Add clause for powerpc64-*-linux* * configure.tgt: Add clause for powerpc64-*-linux* * elfread.c (record_minimal_symbol_and_info): If DROP_TEXT_NAME_PREFIX_CHAR is #defined, then drop a leading instance of that char from the names of text symbols. (elf_symtab_read): If SKIP_DATA_IN_OPD is #defined, ignore data symbols in the .opd section. * ppc-linux-nat.c (PTRACE_XFER_TYPE): Change the default for this to 'long'. (PPC_PTRACE_POKEUSR_3264, PPC_PTRACE_PEEKUSR_3264, PPC_PTRACE_POKEDATA_3264, PPC_PTRACE_PEEKDATA_3264): Provide default definitions for these. (ARCH64): New macro. (ppc_wordsize_pid): New function. (kernel_u_size): Handle 64-bit case. (ppc_register_u_addr): Same. (fetch_register): Use the *_3264 requests when debugging a 64-bit process from a 32-bit GDB. (store_register): Same. (GDB_MAX_ALLOCA, child_xfer_memory, udot_info): Copied from infptrace.c. (_initialize_ppc_linux_nat): New function, to register our copy of the udot_info command. * ppc-linux-tdep.c (TDEP): New macro. (ppc64_linux_svr4_fetch_link_map_offsets): New function. (read_memory_addr): Copied from rs6000-tdep.c. (ppc64_linux_convert_from_func_ptr_addr): New function. * rs6000-tdep.c (skip_prologue): Recognize more instructions for saving the 'lr' and 'cr' registers; don't just pre-emptively mask in the 'st' opcode as soon as we see an 'mflr' or 'mfcr' opcode. Recognize more instructions for updating the stack pointer, and loading the TOC pointer. (registers_powerpc64, registers_a35): New register tables. (rs6000_gdbarch_init): Register the 64-bit solib functions. * solib-svr4.c (solib_break_names): If SOLIB_BREAK_NAME is #defined, include an entry for it. (enable_break): Call CONVERT_FROM_FUNC_PTR_ADDR when trying to guess the linker's base address. * config/powerpc/tm-linux.h (ppc64_linux_svr4_fetch_link_map_offsets, ppc64_linux_convert_from_func_ptr_addr): New declarations.
Diffstat (limited to 'gdb/gdbtk/plugins/configure.in')
-rw-r--r--gdb/gdbtk/plugins/configure.in93
1 files changed, 0 insertions, 93 deletions
diff --git a/gdb/gdbtk/plugins/configure.in b/gdb/gdbtk/plugins/configure.in
deleted file mode 100644
index 58a54808124..00000000000
--- a/gdb/gdbtk/plugins/configure.in
+++ /dev/null
@@ -1,93 +0,0 @@
-AC_INIT(Make-rules)
-AC_CONFIG_AUX_DIR(../../..)
-AM_INIT_AUTOMAKE(insight, 1.0)
-AM_MAINTAINER_MODE
-AC_PROG_MAKE_SET
-AC_CANONICAL_HOST
-AC_PROG_CC
-AC_OBJEXT
-AC_EXEEXT
-
-# Find Tcl, Tk, etc
-CYG_AC_PATH_TCLCONFIG
-CYG_AC_LOAD_TCLCONFIG
-CYG_AC_PATH_TKCONFIG
-CYG_AC_LOAD_TKCONFIG
-CYG_AC_PATH_TCLH
-CYG_AC_PATH_TKH
-AC_SUBST(TCL_DBGX)
-
-# Make sure TCL_SHLIB_SUFFIX is set
-if test x$TCL_SHLIB_SUFFIX = x ; then
- case "${host}" in
- *cygwin*) TCL_SHLIB_SUFFIX=".dll" ;;
- *) TCL_SHILB_SUFFIX=".so" ;;
- esac
-fi
-AC_SUBST(TCL_SHLIB_SUFFIX)
-
-# Since we're not using autoconf > 2.1x, we cannot use AC_CONFIG_FILES.
-make_subdirs=""
-
-# See if -mwin32 works for cygwin
-case "${host}" in
- *cygwin*)
- ocflags=${CFLAGS}
- CFLAGS="${CFLAGS} -mwin32"
- AC_TRY_COMPILE(,,,CFLAGS="${ocflags}")
- ;;
- *) ;;
-esac
-
-# note toplevel plugin build directory
-plugin_builddir=`pwd`
-
-#
-# Plugins
-#
-
-# Supported hosts
-
-# Only supported/tested on linux, solaris, cygwin
-supported=yes
-case "${host}" in
- *cygwin*) ;;
- *solaris*) ;;
- *linux*) ;;
- *) supported=no ;;
-esac
-
-# Host-specific configury
-case "${host}" in
- *cygwin*)
- AC_CHECK_TOOL(NM, nm, nm)
- AC_CHECK_TOOL(AS, as, as)
- AC_CHECK_TOOL(LD, ld, ld)
- AC_MSG_CHECKING("for libcygwin.a")
- LIBCYGWIN_A=`$CC -print-file-name=libcygwin.a`
- AC_MSG_RESULT($LIBCYGWIN_A)
- AC_SUBST(LIBCYGWIN_A)
- AC_CHECK_TOOL(DLLTOOL, dlltool)
- ;;
-esac
-
-# Plugins supported by this configuration
-if test x${supported} = xyes; then
- plugins="rhabout"
- case "${target}" in
- *cygwin*) ;;
- *linux*) ;;
- *i?86*)
- plugins="${plugins} intel-pentium"
- ;;
- esac
-
- for i in $plugins ; do
- make_subdirs="${make_subdirs} $i"
- done
-fi
-
-AC_SUBST(make_subdirs)
-AC_SUBST(plugin_builddir)
-
-AC_OUTPUT(Makefile rhabout/Makefile:rhabout/Makefile.in:Make-rules rhabout/rhabout.tcl intel-pentium/Makefile:intel-pentium/Makefile.in:Make-rules intel-pentium/intel-pentium.tcl)