summaryrefslogtreecommitdiff
path: root/libdecnumber/configure.ac
diff options
context:
space:
mode:
authorDJ Delorie <dj@delorie.com>2013-10-16 00:29:39 +0000
committerDJ Delorie <dj@delorie.com>2013-10-16 00:29:39 +0000
commit30e15c23f92d7a42f69bcf55f2ec9dc58737f11a (patch)
treef2ae1145c41aa97db0bf25dac42e032fb653b2ed /libdecnumber/configure.ac
parentc1f569929234e16f3700283a63c1f4c476466ca4 (diff)
downloadgdb-30e15c23f92d7a42f69bcf55f2ec9dc58737f11a.tar.gz
merge from gcc
Diffstat (limited to 'libdecnumber/configure.ac')
-rw-r--r--libdecnumber/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/libdecnumber/configure.ac b/libdecnumber/configure.ac
index 6cfc8033eae..dd0499c43f6 100644
--- a/libdecnumber/configure.ac
+++ b/libdecnumber/configure.ac
@@ -95,6 +95,13 @@ AC_SUBST(ADDITIONAL_OBJS)
AC_C_BIGENDIAN
+# Enable --enable-host-shared.
+AC_ARG_ENABLE(host-shared,
+[AS_HELP_STRING([--enable-host-shared],
+ [build host code as shared libraries])],
+[PICFLAG=-fPIC], [PICFLAG=])
+AC_SUBST(PICFLAG)
+
# Output.
AC_CONFIG_HEADERS(config.h:config.in, [echo timestamp > stamp-h1])