summaryrefslogtreecommitdiff
path: root/readline/configure.in
diff options
context:
space:
mode:
authorJason Molenda <jsm@bugshack.cygnus.com>1999-08-02 23:48:37 +0000
committerJason Molenda <jsm@bugshack.cygnus.com>1999-08-02 23:48:37 +0000
commit6da787a878c938e680f13808dee254beacefbd43 (patch)
tree7c7b4d4f6655b210e33ca51f656f4552c9326ed3 /readline/configure.in
parent1392c9fbbf6fe8811e5374356b7fdf3b389068ab (diff)
downloadgdb-6da787a878c938e680f13808dee254beacefbd43.tar.gz
import gdb-1999-08-02 snapshot
Diffstat (limited to 'readline/configure.in')
-rw-r--r--readline/configure.in42
1 files changed, 36 insertions, 6 deletions
diff --git a/readline/configure.in b/readline/configure.in
index 1e8e7754da2..9afdaa70fcf 100644
--- a/readline/configure.in
+++ b/readline/configure.in
@@ -4,8 +4,8 @@ dnl
dnl report bugs to chet@po.cwru.edu
dnl
dnl Process this file with autoconf to produce a configure script.
-AC_REVISION([for Readline 2.2, version 2.07, from autoconf version] AC_ACVERSION)
-LIBVERSION=2.2
+AC_REVISION([for Readline 4.0, version 2.14, from autoconf version] AC_ACVERSION)
+LIBVERSION=4.0
AC_INIT(readline.h)
AC_CONFIG_HEADER(config.h)
@@ -34,7 +34,6 @@ test -z "$CFLAGS" && CFLAGS=-g auto_cflags=1
AC_PROG_CC
AC_MINIX
-
dnl BEGIN changes for CYGNUS cross-building for Cygwin
dnl load up the cross-building cache file -- add more cases and cache
@@ -73,15 +72,20 @@ AC_SUBST(CC_FOR_BUILD)
dnl END changes for CYGNUS cross-building for Cygwin
-
-
# If we're using gcc and the user hasn't specified CFLAGS, add -O to CFLAGS.
test -n "$GCC" && test -n "$auto_cflags" && CFLAGS="$CFLAGS -O"
AC_PROG_GCC_TRADITIONAL
AC_PROG_INSTALL
+AC_CHECK_PROG(AR, ar, ar)
+dnl Set default for ARFLAGS, since autoconf does not have a macro for it.
+dnl This allows people to set it when running configure or make
+test -n "$ARFLAGS" || ARFLAGS="cr"
AC_PROG_RANLIB
+MAKE_SHELL=/bin/sh
+AC_SUBST(MAKE_SHELL)
+
AC_RETSIGTYPE
AC_HEADER_STAT
@@ -129,6 +133,29 @@ case "$host_os" in
isc*) LOCAL_CFLAGS=-Disc386 ;;
esac
+# shared library configuration section
+#
+# Shared object configuration section. These values are generated by
+# ${srcdir}/support/shobj-conf
+#
+if test -f ${srcdir}/support/shobj-conf; then
+ AC_MSG_CHECKING(configuration for building shared libraries)
+ eval `${CONFIG_SHELL-/bin/sh} ${srcdir}/support/shobj-conf -C ${CC} -c ${host_cpu} -o ${host_os} -v ${host_vendor}`
+ AC_SUBST(SHOBJ_CC)
+ AC_SUBST(SHOBJ_CFLAGS)
+ AC_SUBST(SHOBJ_LD)
+ AC_SUBST(SHOBJ_LDFLAGS)
+ AC_SUBST(SHOBJ_XLDFLAGS)
+ AC_SUBST(SHOBJ_LIBS)
+ AC_SUBST(SHOBJ_STATUS)
+ AC_SUBST(SHLIB_STATUS)
+ AC_SUBST(SHLIB_XLDFLAGS)
+ AC_SUBST(SHLIB_LIBSUFF)
+ AC_SUBST(SHLIB_LIBVERSION)
+ AC_SUBST(SHLIB_LIBS)
+ AC_MSG_RESULT($SHLIB_STATUS)
+fi
+
BUILD_DIR=`pwd`
AC_SUBST(BUILD_DIR)
@@ -137,6 +164,9 @@ AC_SUBST(LOCAL_CFLAGS)
AC_SUBST(LOCAL_LDFLAGS)
AC_SUBST(LOCAL_DEFS)
+AC_SUBST(AR)
+AC_SUBST(ARFLAGS)
+
AC_SUBST(host_cpu)
AC_SUBST(host_os)
@@ -144,7 +174,7 @@ AC_SUBST(LIBVERSION)
AC_SUBST(TERMCAP_LIB)
-AC_OUTPUT([Makefile doc/Makefile examples/Makefile],
+AC_OUTPUT([Makefile doc/Makefile examples/Makefile shlib/Makefile],
[
# Makefile uses this timestamp file to record whether config.h is up to date.
echo > stamp-h