summaryrefslogtreecommitdiff
path: root/sim/frv/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-03-31 00:39:34 +0000
committerMike Frysinger <vapier@gentoo.org>2013-03-31 00:39:34 +0000
commit0b2e20369678b2abe472bfbd4aa6e2e46b8c9f9f (patch)
tree2e447347b5e8bbb9eed374bbfc636ae91ddd30ec /sim/frv/configure.ac
parenteecd1738518f4743b077307b4ee1a0074f68b3c8 (diff)
downloadgdb-0b2e20369678b2abe472bfbd4aa6e2e46b8c9f9f.tar.gz
sim: frv/m32r: back out hard failure when dv-sockser is not available
These sims have optional support for the dv-sockser model, so do not make them hard failures. The Makefile made it seem like they didn't actually support things dynamically, but a further code dive into the source and the Makefile shows that things work out.
Diffstat (limited to 'sim/frv/configure.ac')
-rw-r--r--sim/frv/configure.ac8
1 files changed, 2 insertions, 6 deletions
diff --git a/sim/frv/configure.ac b/sim/frv/configure.ac
index 68487abc2f3..df888d93f8e 100644
--- a/sim/frv/configure.ac
+++ b/sim/frv/configure.ac
@@ -29,11 +29,7 @@ fi],[sim_trapdump=""])dnl
AC_SUBST(sim_trapdump)
SIM_AC_OPTION_HARDWARE(always,"","")
-
-if test -z "$SIM_DV_SOCKSER_O"; then
- AC_MSG_ERROR([Sorry, but hardware support in this simulator
-unconditionally relies on dv-sockser.o which is unavailable for your host.
-Please fix this simulator.])
-fi
+frv_extra_objs="$SIM_DV_SOCKSER_O"
+AC_SUBST(frv_extra_objs)
SIM_AC_OUTPUT