summaryrefslogtreecommitdiff
path: root/sim/msp430/configure.ac
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2013-06-21 10:59:12 +0000
committerNick Clifton <nickc@redhat.com>2013-06-21 10:59:12 +0000
commit8eaac0c2c003423056f33308d6bc7e268af8fbc0 (patch)
tree6fea4388e376200e5676600f75bf311a74e78cde /sim/msp430/configure.ac
parent5c5458af8483dc197098ad3e90502a4b2a9746ad (diff)
downloadgdb-8eaac0c2c003423056f33308d6bc7e268af8fbc0.tar.gz
* msp430: New Directory.
* configure.tgt: Add it. * configure: Regenerate. * gennltvals.sh: Add msp430 support. * nltvals.def: Regenerate. * Makefile.in: New. * aclocal.m4: Generate. * config.in: Generate. * configure.ac: New. * configure: Generate. * msp430-sim.c: New. * msp430-sim.h: New. * sim-main.h: New. * trace.c: New. * trace.h: New.
Diffstat (limited to 'sim/msp430/configure.ac')
-rw-r--r--sim/msp430/configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/sim/msp430/configure.ac b/sim/msp430/configure.ac
new file mode 100644
index 00000000000..fccf6d7b4c5
--- /dev/null
+++ b/sim/msp430/configure.ac
@@ -0,0 +1,32 @@
+dnl Process this file with autoconf to produce a configure script.
+
+dnl Copyright (C) 2005, 2007-2013 Free Software Foundation, Inc.
+dnl Contributed by Red Hat, Inc.
+dnl
+dnl This file is part of the GNU simulators.
+dnl
+dnl This program is free software; you can redistribute it and/or modify
+dnl it under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation; either version 3 of the License, or
+dnl (at your option) any later version.
+dnl
+dnl This program is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+dnl GNU General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU General Public License
+dnl along with this program. If not, see <http://www.gnu.org/licenses/>.
+dnl
+AC_PREREQ(2.64)dnl
+AC_INIT(Makefile.in)
+sinclude(../common/acinclude.m4)
+
+SIM_AC_COMMON
+
+AC_CHECK_HEADERS(getopt.h)
+
+SIM_AC_OPTION_ENDIAN(LITTLE_ENDIAN)
+SIM_AC_OPTION_ALIGNMENT(STRICT_ALIGNMENT,STRICT_ALIGNMENT)
+
+SIM_AC_OUTPUT