summaryrefslogtreecommitdiff
path: root/sim/ppc/configure.ac
diff options
context:
space:
mode:
authorAndreas Schwab <schwab@suse.de>2006-05-05 17:11:19 +0000
committerAndreas Schwab <schwab@suse.de>2006-05-05 17:11:19 +0000
commitdcd77ffb9cb6b61be89e6d45e9352f439cf68f65 (patch)
tree4fe141be90ac96ae306a55881bcd477382853131 /sim/ppc/configure.ac
parentacc83f2a87d6c5aff3cbae504051e40059e5a080 (diff)
downloadgdb-dcd77ffb9cb6b61be89e6d45e9352f439cf68f65.tar.gz
sim/:
* configure.ac (CFLAGS_FOR_BUILD): Set and substitute. * configure: Regenerate. * Makefile.in (CFLAGS_FOR_BUILD): Define. (CC_FOR_BUILD): Don't override. (FLAGS_TO_PASS): Pass CFLAGS_FOR_BUILD. sim/ppc/: * configure.ac (CFLAGS_FOR_BUILD): Set and substitute. * configure: Regenerate. * Makefile.in (CFLAGS_FOR_BUILD): Define. (BUILD_CFLAGS): Use it instead of hardcoding "-g -O". (gentmap): Fix typo BUILD_FLAGS -> BUILD_CFLAGS.
Diffstat (limited to 'sim/ppc/configure.ac')
-rw-r--r--sim/ppc/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/sim/ppc/configure.ac b/sim/ppc/configure.ac
index c51553f93d0..83a12fb01fb 100644
--- a/sim/ppc/configure.ac
+++ b/sim/ppc/configure.ac
@@ -12,6 +12,7 @@ if test "x$cross_compiling" = "xno"; then
else
CC_FOR_BUILD=gcc
fi
+CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
dnl We don't use gettext, but bfd does. So we do the appropriate checks
dnl to see if there are intl libraries we should link against.
@@ -747,6 +748,7 @@ dnl Check for exe extension
AC_EXEEXT
AC_SUBST(CC_FOR_BUILD)
+AC_SUBST(CFLAGS_FOR_BUILD)
AC_SUBST(CFLAGS)
AC_SUBST(HDEFINES)
AR=${AR-ar}