summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac33
1 files changed, 31 insertions, 2 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 39246aab825..8380c042241 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -381,9 +381,12 @@ AC_CHECK_TOOL(MIG, mig)
# We might need to link with -lm; most simulators need it.
AC_CHECK_LIB(m, main)
+AC_CHECK_FUNC(inflate, [],
+ [AC_CHECK_LIB(z, inflate)])
+
# We need to link with -lw to get `wctype' on Solaris before Solaris
# 2.6. Solaris 2.6 and beyond have this function in libc, and have a
-# libw that some versions of the GNU linker cannot hanle (GNU ld 2.9.1
+# libw that some versions of the GNU linker cannot handle (GNU ld 2.9.1
# is known to have this problem). Therefore we avoid libw if we can.
AC_CHECK_FUNC(wctype, [],
[AC_CHECK_LIB(w, wctype)])
@@ -477,6 +480,32 @@ else
fi
fi
+
+AC_ARG_WITH(xiss,
+ AS_HELP_STRING([--with-xiss], [include xiss support (auto/yes/no)]),
+ [], [with_xiss=auto])
+AC_MSG_CHECKING([whether to use xiss])
+AC_MSG_RESULT([$with_xiss])
+
+if test "${with_xiss}" = yes; then
+ HAVE_LIBXISS=yes
+ AC_DEFINE(HAVE_LIBXISS, 1, [Define if you have the xISS library.])
+ XISS_INCLUDES="-I${with_xiss_prefix}/include"
+ AC_SUBST(XISS_INCLUDES)
+else
+ AC_MSG_WARN([xiss support disabled; target arcxiss will be unavailable.])
+ HAVE_LIBXISS=no
+fi
+
+
+if test "${target}" = "arc-unknown-elf32"; then
+ AC_DEFINE(ARC_ELF32_TARGET, 1, [Define if you are building the ARC bare-board debugger.])
+fi
+if test "${target}" = "arc-unknown-linux-uclibc"; then
+ AC_DEFINE(ARC_LINUX_TARGET, 1, [Define if you are building the ARC Linux debugger.])
+fi
+
+
# ------------------------- #
# Checks for header files. #
# ------------------------- #
@@ -1414,7 +1443,7 @@ OLD_LIBS=$LIBS
CFLAGS="$CFLAGS -I${srcdir}/../include -I../bfd -I${srcdir}/../bfd"
LDFLAGS="$LDFLAGS -L../bfd -L../libiberty"
intl=`echo $LIBINTL | sed 's,${top_builddir}/,,g'`
-LIBS="$LIBS -lbfd -liberty $intl"
+LIBS="$LIBS -lbfd -liberty $intl -lz"
AC_CACHE_CHECK([for ELF support in BFD], gdb_cv_var_elf,
[AC_TRY_LINK(
[#include <stdlib.h>