summaryrefslogtreecommitdiff
path: root/newlib/libc/machine/cris/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/machine/cris/Makefile.am')
-rw-r--r--newlib/libc/machine/cris/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/newlib/libc/machine/cris/Makefile.am b/newlib/libc/machine/cris/Makefile.am
new file mode 100644
index 00000000000..de82dd18792
--- /dev/null
+++ b/newlib/libc/machine/cris/Makefile.am
@@ -0,0 +1,23 @@
+## Process this file with automake to generate Makefile.in
+
+AUTOMAKE_OPTIONS = cygnus
+
+INCLUDES = $(NEWLIB_CFLAGS) $(CROSS_CFLAGS) $(TARGET_CFLAGS)
+
+AM_CCASFLAGS = $(INCLUDES)
+
+noinst_LIBRARIES = lib.a
+
+# We also make a library with just the useful
+# machine-but-not-system-specific functions, usable as an add-on
+# by itself together with e.g. uclibc.
+toollib_LIBRARIES = libic.a
+
+lib_a_SOURCES = setjmp.c memcpy.c memset.c memmove.c libcdtor.c
+
+libic_a_SOURCES = setjmp.c memcpy.c memset.c memmove.c libcdtor.c
+tooldir = $(exec_prefix)/$(host_alias)
+toollibdir = $(tooldir)/lib$(MULTISUBDIR)
+
+ACLOCAL_AMFLAGS = -I ../../..
+CONFIG_STATUS_DEPENDENCIES = $(newlib_basedir)/configure.host