summaryrefslogtreecommitdiff
path: root/newlib/libc/machine/i386/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/machine/i386/Makefile.am')
-rw-r--r--newlib/libc/machine/i386/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/newlib/libc/machine/i386/Makefile.am b/newlib/libc/machine/i386/Makefile.am
new file mode 100644
index 00000000000..7de099e849e
--- /dev/null
+++ b/newlib/libc/machine/i386/Makefile.am
@@ -0,0 +1,20 @@
+## Process this file with automake to generate Makefile.in
+
+AUTOMAKE_OPTIONS = cygnus
+
+INCLUDES = -I $(newlib_basedir)/libm/common $(NEWLIB_CFLAGS) $(CROSS_CFLAGS) $(TARGET_CFLAGS)
+
+noinst_LIBRARIES = lib.a
+
+if MACH_ADD_SETJMP
+mach_add_src=setjmp.S
+else
+mach_add_src=
+endif
+
+lib_a_SOURCES = \
+ memchr.S memcmp.S memcpy.S memset.S strchr.S \
+ $(mach_add_src)
+
+ACLOCAL_AMFLAGS = -I ../../..
+CONFIG_STATUS_DEPENDENCIES = $(newlib_basedir)/configure.host