summaryrefslogtreecommitdiff
path: root/newlib/libc/sys/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/sys/configure.in')
-rw-r--r--newlib/libc/sys/configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/newlib/libc/sys/configure.in b/newlib/libc/sys/configure.in
new file mode 100644
index 00000000000..ea674904165
--- /dev/null
+++ b/newlib/libc/sys/configure.in
@@ -0,0 +1,24 @@
+dnl This is the newlib/libc/sys configure.in file.
+dnl Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.5)
+AC_INIT(a29khif)
+
+dnl Can't be done in NEWLIB_CONFIGURE because that confuses automake.
+AC_CONFIG_AUX_DIR(../../..)
+
+NEWLIB_CONFIGURE(../..)
+
+if test -n "${sys_dir}"; then
+ AC_CONFIG_SUBDIRS(${sys_dir})
+fi
+
+CRT0=
+if test -n "${sys_dir}"; then
+ CRT0=crt0.o
+fi
+AC_SUBST(CRT0)
+
+AM_CONDITIONAL(HAVE_SYS_DIR, test x${sys_dir} != x)
+
+AC_OUTPUT(Makefile)