summaryrefslogtreecommitdiff
path: root/newlib/libc/unix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/unix/Makefile.am')
-rw-r--r--newlib/libc/unix/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/newlib/libc/unix/Makefile.am b/newlib/libc/unix/Makefile.am
new file mode 100644
index 00000000000..ae8e92f9599
--- /dev/null
+++ b/newlib/libc/unix/Makefile.am
@@ -0,0 +1,27 @@
+## Process this file with automake to generate Makefile.in
+
+AUTOMAKE_OPTIONS = cygnus
+
+INCLUDES = $(NEWLIB_CFLAGS) $(CROSS_CFLAGS) $(TARGET_CFLAGS)
+
+noinst_LIBRARIES = lib.a
+
+lib_a_SOURCES = \
+ getpass.c sigset.c getpwent.c ttyname.c getut.c getlogin.c getcwd.c
+
+CHEWOUT_FILES =
+
+SUFFIXES = .def
+
+CHEW = ../../doc/makedoc -f $(srcdir)/../../doc/doc.str
+
+.c.def:
+ $(CHEW) < $< > $*.def 2> $*.ref
+ touch stmp-def
+
+TARGETDOC = ../tmp.texi
+
+# No doc for unix.
+doc:
+
+CLEANFILES = $(CHEWOUT_FILES) *.ref