summaryrefslogtreecommitdiff
path: root/sim/mn10300/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sim/mn10300/configure.ac')
-rw-r--r--sim/mn10300/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/sim/mn10300/configure.ac b/sim/mn10300/configure.ac
index 8916c85f7cc..d4449beaaa6 100644
--- a/sim/mn10300/configure.ac
+++ b/sim/mn10300/configure.ac
@@ -17,4 +17,12 @@ SIM_AC_OPTION_HARDWARE(yes,,mn103cpu mn103int mn103tim mn103ser mn103iop)
AC_CHECK_FUNCS(time chmod utime fork execve execv chown)
AC_CHECK_HEADERS(unistd.h stdlib.h string.h strings.h utime.h time.h)
+SIM_AC_OPTION_HARDWARE(always,"","")
+
+if test -z "$SIM_DV_SOCKSER_O"; then
+ AC_MSG_ERROR([Sorry, but hardware support in this simulator
+unconditionally relies on dv-sockser.o which is unavailable for your host.
+Please fix this simulator.])
+fi
+
SIM_AC_OUTPUT