summaryrefslogtreecommitdiff
path: root/tcl/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'tcl/configure.in')
-rw-r--r--tcl/configure.in33
1 files changed, 33 insertions, 0 deletions
diff --git a/tcl/configure.in b/tcl/configure.in
new file mode 100644
index 00000000000..4286ff547fd
--- /dev/null
+++ b/tcl/configure.in
@@ -0,0 +1,33 @@
+dnl This file is used as input to autoconf to generate configure.
+dnl The only reason we need this is that the Tcl directory structure
+dnl changed in 7.5, and this change lets us avoid changing the
+dnl configuration superstructure.
+dnl Tom Tromey <tromey@cygnus.com>
+
+AC_PREREQ(2.5)
+
+AC_INIT(generic/tcl.h)
+
+AC_CANONICAL_HOST
+
+case "${host}" in
+*-*-cygwin*)
+ CONFIGDIR="win"
+ AC_SUBST(CONFIGDIR)
+ CONFIGDIR2="cygwin"
+ AC_SUBST(CONFIGDIR2)
+ ;;
+*-*-mingw32*)
+ CONFIGDIR="win"
+ AC_SUBST(CONFIGDIR)
+ ;;
+*)
+ CONFIGDIR="unix"
+ AC_SUBST(CONFIGDIR)
+ AC_CONFIG_AUX_DIR($CONFIGDIR)
+ ;;
+esac
+
+AC_PROG_MAKE_SET
+AC_CONFIG_SUBDIRS($CONFIGDIR $CONFIGDIR2)
+AC_OUTPUT(Makefile)