summaryrefslogtreecommitdiff
path: root/gdk-pixbuf/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2017-08-03 17:27:08 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2017-08-17 15:13:37 +0800
commit6ce0b0bca07ffc709f46abb7bec1b88a5fe5df4a (patch)
treeca7ec86b1c1ebc872be8f2408db9ed7bf0bf637c /gdk-pixbuf/meson.build
parent82f40a6f0502c31c1086840df61e1f67c7d523f9 (diff)
downloadgdk-pixbuf-6ce0b0bca07ffc709f46abb7bec1b88a5fe5df4a.tar.gz
build: Fix Meson builds using builtin loaders
We need to ensure that the loaders that are to be built into the main GDK-Pixbuf library is built as follows: -The individual loader sources are built with the corresponding INCLUDE_xxx macro defined. -The GDK-Pixbuf library itself must be built with all of the INCLUDE_xxx macros defined for building the individual loaders that we are building into the main GDK-Pixbuf library There is also a typo for the macro to make the loaders built into the GDK-Pixbuf library, so correct that as well (-DINCLUDED_xxx -> -DINCLUDE_xxx). https://bugzilla.gnome.org/show_bug.cgi?id=785767
Diffstat (limited to 'gdk-pixbuf/meson.build')
-rw-r--r--gdk-pixbuf/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/gdk-pixbuf/meson.build b/gdk-pixbuf/meson.build
index bc4ef4ff2..f15ad2bdb 100644
--- a/gdk-pixbuf/meson.build
+++ b/gdk-pixbuf/meson.build
@@ -99,13 +99,14 @@ foreach l: loaders
cond = l.get(2, true)
if cond and builtin_loaders.contains(name)
- included_loaders_cflags += '-DINCLUDED_@0@'.format(name)
+ cflag_for_included_loader = ['-DINCLUDE_@0@'.format(name)]
+ included_loaders_cflags += cflag_for_included_loader
mod = static_library('staticpixbufloader-@0@'.format(name),
sources,
dependencies: loaders_deps + gdk_pixbuf_deps,
include_directories: [ root_inc, gdk_pixbuf_inc ],
- c_args: common_cflags + gdk_pixbuf_cflags)
+ c_args: common_cflags + gdk_pixbuf_cflags + cflag_for_included_loader)
included_loaders_deps += declare_dependency(link_with: mod)
endif