summaryrefslogtreecommitdiff
path: root/glib/Makefile.am
diff options
context:
space:
mode:
authorElliot Lee <sopwith@src.gnome.org>1997-11-24 22:37:52 +0000
committerElliot Lee <sopwith@src.gnome.org>1997-11-24 22:37:52 +0000
commit9508b76bd2401b6b9e289b5c8ec9fc0e08909283 (patch)
tree53c88a9e5ac09e1a027e56df33bdaa66d670901b /glib/Makefile.am
downloadgdk-pixbuf-9508b76bd2401b6b9e289b5c8ec9fc0e08909283.tar.gz
Initial revision
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
new file mode 100644
index 000000000..18afb93a5
--- /dev/null
+++ b/glib/Makefile.am
@@ -0,0 +1,38 @@
+## Process this file with automake to produce Makefile.in
+
+lib_LTLIBRARIES = libglib.la
+
+libglib_la_SOURCES = \
+ garray.c \
+ gcache.c \
+ gerror.c \
+ ghash.c \
+ glist.c \
+ gmem.c \
+ gprimes.c \
+ gslist.c \
+ gtimer.c \
+ gtree.c \
+ gutils.c \
+ gstring.c
+
+include_HEADERS = \
+ glib.h \
+ glibconfig.h
+
+libglib_la_LDFLAGS = -version-info 1:0:0
+
+INCLUDES =
+
+noinst_PROGRAMS = testglib
+testglib_LDADD = $(top_builddir)/libglib.la
+
+.PHONY: files release
+
+files:
+ @files=`ls $(DISTFILES) 2> /dev/null `; for p in $$files; do \
+ echo $$p; \
+ done
+
+release:
+ $(MAKE) dist distdir=$(PACKAGE)`date +"%y%m%d"`