summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorJonathan Blandford <jrb@redhat.com>2001-09-17 21:44:20 +0000
committerJonathan Blandford <jrb@src.gnome.org>2001-09-17 21:44:20 +0000
commita25167914836070833b1720933d048ba82a40c64 (patch)
tree0c86d02687e6bef28c3d983e1f7792edce462c4d /gtk/Makefile.am
parentef79a175b51bf5924d63b15c11bb7987857f10bd (diff)
downloadgdk-pixbuf-a25167914836070833b1720933d048ba82a40c64.tar.gz
Add editable interface. This should be the last big GtkTreeView API
Mon Sep 17 17:39:52 2001 Jonathan Blandford <jrb@redhat.com> * gtk/gtkcelleditable.[ch]: Add editable interface. This should be the last big GtkTreeView API change. * gtk/gtkcellrenderer.[ch]: Get rid of the "event" vfunc, and replace with "activate" and "start_editing". Also, added a "can_activate" and "can_edit" property. * gtk/gtktreeviewcolumn.c: modify to use above.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 4bd9f48b8..77c92c453 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -69,6 +69,7 @@ gtk_public_h_sources = @STRIP_BEGIN@ \
gtkctree.h \
gtkcurve.h \
gtkcellrenderer.h \
+ gtkcelleditable.h \
gtkcellrenderertext.h \
gtkcellrenderertoggle.h \
gtkcellrendererpixbuf.h \
@@ -215,6 +216,7 @@ gtk_c_sources = @STRIP_BEGIN@ \
gtkbutton.c \
gtkcalendar.c \
gtkcellrenderer.c \
+ gtkcelleditable.c \
gtkcellrenderertext.c \
gtkcellrenderertoggle.c \
gtkcellrendererpixbuf.c \