summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-05-31 21:20:08 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2018-05-31 21:20:08 +0100
commit1bce68c5601d47360d1e809ce494aa01ce162132 (patch)
treee7267b41e5d91b3b00f24978b6687ffb92c455fc /meson.build
parent95512220773b898c8c5da8da4193a007bd6b36f1 (diff)
downloadgdk-pixbuf-1bce68c5601d47360d1e809ce494aa01ce162132.tar.gz
build: Add symbols for platform detection
We're missing OS_LINUX and OS_DARWIN pre-processor symbols.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 4ac16ece0..ce391b912 100644
--- a/meson.build
+++ b/meson.build
@@ -170,19 +170,21 @@ endif
common_cflags += cc.get_supported_arguments(test_cflags)
-# Linker flags
if host_machine.system() == 'linux'
+ # Additional linker flags
test_ldflags = ['-Wl,-Bsymbolic', '-Wl,-z,relro', '-Wl,-z,now']
if meson.version().version_compare('>= 0.46.0')
common_ldflags += cc.get_supported_link_arguments(test_ldflags)
else
common_ldflags += test_ldflags
endif
+ gdk_pixbuf_conf.set('OS_LINUX', 1)
endif
-# Maintain compatibility with autotools on macOS
if host_machine.system() == 'darwin'
+ # Maintain compatibility with autotools on macOS
common_ldflags += [ '-compatibility_version 1', '-current_version 1.0', ]
+ gdk_pixbuf_conf.set('OS_DARWIN', 1)
endif
# Dependencies