summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-01-04 00:40:53 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2021-01-04 00:40:53 +0000
commit2839b5ce73e385956cb3b7ea7a8317871ce30502 (patch)
tree9a0ed121d741ac5597d8b23ad97fc1072d961175 /meson.build
parentc1c91ac39a0cdf8a575fc8746b15d01559f92815 (diff)
downloadgdk-pixbuf-2839b5ce73e385956cb3b7ea7a8317871ce30502.tar.gz
Pass glib-compile-resources's path to gen-resources.py
Since the gen-resources.py needs to call glib-compile-resources, we need to figure out where the binary is, and tell gen-resources.py to use that, instead of relying on it being in the PATH.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ecb745186..1cef125a3 100644
--- a/meson.build
+++ b/meson.build
@@ -371,6 +371,9 @@ gen_resources = find_program('build-aux/gen-resources.py')
gen_installed_test = find_program('build-aux/gen-installed-test.py')
gen_thumbnailer = find_program('build-aux/gen-thumbnailer.py')
+# Needed by gen-resources.py
+glib_compile_resources = find_program('glib-compile-resources')
+
gnome = import('gnome')
subdir('gdk-pixbuf')