summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2017-11-29 18:01:40 +0100
committerBastien Nocera <hadess@hadess.net>2017-12-05 06:46:55 +0100
commit328b53f0b67293c5b310d4e1ce9894a83644416f (patch)
tree6e7713057fa63a86e1976c1d8163df52f222462a /meson.build
parentb99e04f116972d2ee355fb129238cc574bd58dd3 (diff)
downloadgdk-pixbuf-328b53f0b67293c5b310d4e1ce9894a83644416f.tar.gz
build: Remove "enable" from Meson build options
As per https://wiki.gnome.org/Initiatives/GnomeGoals/MesonPorting https://bugzilla.gnome.org/show_bug.cgi?id=790995
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 10 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index 466a5c3e3..4bd0af53f 100644
--- a/meson.build
+++ b/meson.build
@@ -214,7 +214,7 @@ endif
enabled_loaders = []
loaders_deps = []
-if get_option('enable_png')
+if get_option('png')
# We have a vast selection of libpng versions to choose from
foreach png: [ 'libpng16', 'libpng15', 'libpng14', 'libpng13', 'libpng12', 'libpng10' ]
if not enabled_loaders.contains('png')
@@ -260,19 +260,19 @@ endif
# Note that we currently do not use the native Windows loaders to handle PNG and
# JPEG2000 images
if host_system == 'windows'
- enable_native_windows_loaders = get_option('enable_native_windows_loaders')
+ native_windows_loaders = get_option('native_windows_loaders')
else
- enable_native_windows_loaders = false
+ native_windows_loaders = false
endif
-if enable_native_windows_loaders
+if native_windows_loaders
loaders_deps += cc.find_library('gdiplus')
loaders_deps += cc.find_library('ole32')
enabled_loaders += 'gdiplus'
endif
-# Don't check and build the jpeg loader if enable_native_windows_loaders is true
-if get_option('enable_jpeg') and not enable_native_windows_loaders
+# Don't check and build the jpeg loader if native_windows_loaders is true
+if get_option('jpeg') and not native_windows_loaders
if cc.has_header('jpeglib.h')
jpeg_dep = cc.find_library('jpeg', required: false)
if cc.get_id() == 'msvc' and not jpeg_dep.found()
@@ -290,8 +290,8 @@ if get_option('enable_jpeg') and not enable_native_windows_loaders
endif
endif
-# Don't check and build the tiff loader if enable_native_windows_loaders is true
-if get_option('enable_tiff') and not enable_native_windows_loaders
+# Don't check and build the tiff loader if native_windows_loaders is true
+if get_option('tiff') and not native_windows_loaders
tiff_dep = dependency('libtiff-4', required: false)
if not tiff_dep.found()
# Fallback when no pkg-config file is found for libtiff on MSVC, which is quite normal
@@ -314,7 +314,7 @@ endif
jasper_extra_cflags = []
-if get_option('enable_jasper')
+if get_option('jasper')
has_jasper_header = false
if cc.get_id() == 'msvc'
@@ -347,7 +347,7 @@ endif
if host_system == 'windows'
relocatable = true
else
- relocatable = get_option('enable_relocatable')
+ relocatable = get_option('relocatable')
endif
if relocatable