summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-04-07 17:21:16 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2021-04-07 18:08:15 +0100
commit437cc45d8f74abbc678b6d5b0ca0fbf08f9f72a3 (patch)
tree354c299f2a05341cea63773370f31b6c3b27bf2a /meson.build
parent7bea10fd61f708805657a5a44fca548bd31ebbe9 (diff)
downloadgdk-pixbuf-437cc45d8f74abbc678b6d5b0ca0fbf08f9f72a3.tar.gz
Use 'provide' section in libpng wrap file
Avoid hard-coding the dependency object into the meson.build file.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index df1800df3..d0f4a7b62 100644
--- a/meson.build
+++ b/meson.build
@@ -281,7 +281,7 @@ if get_option('png')
# that will bypass --wrap-mode and cause issues for distro packagers.
# See: https://mesonbuild.com/Reference-manual.html#dependency
if not png_dep.found()
- png_dep = dependency('', required: false, fallback: ['libpng', 'png_dep'])
+ png_dep = dependency('', required: false, fallback: 'libpng')
if png_dep.found()
enabled_loaders += 'png'
loaders_deps += png_dep