summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2020-04-01 16:25:26 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2020-06-26 17:26:20 +0100
commit4a278c66bd4f688e5c5a069e9eeba654168c998a (patch)
tree9d3fe0ebaf4d8c48a35aee13c3977a03d577cbec /meson.build
parent79798c0aafe5f2e3cb1546696e2a353f403a200d (diff)
downloadgdk-pixbuf-4a278c66bd4f688e5c5a069e9eeba654168c998a.tar.gz
Remove the libjasper-based JPEG2000 loader
Libjasper is not really maintained any more, and has been dropped by various Linux distributions over the years. GdkPixbuf has not enabled the JPEG2000 loader by default in many years, relying on downstream distributors to do so if they also shipped libjasper. This means that it's unlikely anybody has relied on GdkPixbuf to load a JPEG2000 image for the past 3 to 5 years, if at all. The only other option for loading JPEG2000 images is to use OpenJPEG, and for that there is an out of tree GdkPixbuf module available: https://notabug.org/necklace/jp2-pixbuf-loader Fixes: #152, #137
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build30
1 files changed, 0 insertions, 30 deletions
diff --git a/meson.build b/meson.build
index 8349e5f3b..c1423ddba 100644
--- a/meson.build
+++ b/meson.build
@@ -347,36 +347,6 @@ if get_option('tiff') and not native_windows_loaders
endif
endif
-jasper_extra_cflags = []
-
-if get_option('jasper')
- has_jasper_header = false
-
- if cc.get_id() == 'msvc'
- # We must define JAS_WIN_MSVC_BUILD before including jasper/jasper.h on MSVC
- jasper_msvc_macro = 'JAS_WIN_MSVC_BUILD'
- has_jasper_header = cc.has_header('jasper/jasper.h', prefix: '#define @0@'.format(jasper_msvc_macro))
- jasper_extra_cflags = [ '-D@0@'.format(jasper_msvc_macro) ]
- else
- has_jasper_header = cc.has_header('jasper/jasper.h')
- endif
-
- if has_jasper_header
- jasper_dep = cc.find_library('jasper', required: false)
- if not jasper_dep.found()
- if cc.get_id() == 'msvc'
- # on MSVC, we need to look for libjasper.lib if jasper.lib is not found,
- # which corresponds to what libjasper's MSVC projects produce
- jasper_dep = cc.find_library('libjasper', required: false)
- endif
- endif
- if jasper_dep.found() and cc.has_function('jas_init', dependencies: jasper_dep)
- enabled_loaders += 'jasper'
- loaders_deps += jasper_dep
- endif
- endif
-endif
-
# Determine whether we enable application bundle relocation support, and we use
# this always on Windows
if host_system == 'windows'