summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2017-08-02 13:14:29 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2017-08-02 13:14:29 +0100
commit5e669da4a655868d74833a6e3cc89a803f430aad (patch)
tree6f3397f1db23c7b1fc5a27f952c70e9f5aed8e28 /meson.build
parent5571ecd6a82b3d56c4a107f2c2bda0c14d67cb6f (diff)
downloadgdk-pixbuf-5e669da4a655868d74833a6e3cc89a803f430aad.tar.gz
meson: Support installed tests
We want to be able to run the gdk-pixbuf tests after installing them in a known system location, especially when running CI.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 77757bea7..b0be82acf 100644
--- a/meson.build
+++ b/meson.build
@@ -23,6 +23,8 @@ gdk_pixbuf_version_micro = version_arr[2].to_int()
gdk_pixbuf_api_version = '2.0'
gdk_pixbuf_binary_version = '2.10.0'
+gdk_pixbuf_api_name = '@0@-@1@'.format(meson.project_name(), gdk_pixbuf_api_version)
+
if gdk_pixbuf_version_minor.is_odd()
gdk_pixbuf_interface_age = 0
else