summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2020-06-26 11:15:10 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2020-06-26 11:37:24 +0100
commit716158e6dec609bc973d4242c922cdb57bbcb7ad (patch)
treed621d979073bfdd2ba6ab7d3cfcdeefb374b51bd /meson.build
parent1479726abf1eec3faf6ff4407ade6d9ec4402c98 (diff)
downloadgdk-pixbuf-716158e6dec609bc973d4242c922cdb57bbcb7ad.tar.gz
Add `gtk_doc` build option
And deprecate the `docs` one. The `gtk_doc` option is shared across GNOME modules, so we should conform to the established practice.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index bd4f0dff6..8349e5f3b 100644
--- a/meson.build
+++ b/meson.build
@@ -414,6 +414,7 @@ if not meson.is_cross_build()
endif
# Documentation
+build_docs = get_option('gtk_doc') or get_option('docs')
subdir('docs')
if not meson.is_cross_build()
@@ -444,7 +445,7 @@ summary = [
'',
' enabled loaders: @0@'.format(' '.join(enabled_loaders)),
'',
- ' documentation: @0@'.format(get_option('docs')),
+ ' documentation: @0@'.format(build_docs),
' man pages: @0@'.format(get_option('man')),
' introspection: @0@'.format(get_option('gir')),
' installed tests: @0@'.format(get_option('installed_tests')),