summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-04-16 15:31:29 -0400
committerEmmanuele Bassi <ebassi@gnome.org>2021-04-16 23:33:27 +0100
commit7583d07890ca4ec0ee4e050c24396f21ba410077 (patch)
treea88f3f312ad9bf4cd4aac1b0ac4f6561d9f53012 /meson.build
parent676533c04995bb7777024b16460c115bf37b35dd (diff)
downloadgdk-pixbuf-7583d07890ca4ec0ee4e050c24396f21ba410077.tar.gz
build: Use old syntax for fallback dependencies
With meson 0.56, this can be done more elegantly with allow_fallback and a [provide] section in the wrap files, but with 0.55, we need to explictly mention the variable names in the meson file.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 738e447d4..c07e9cb08 100644
--- a/meson.build
+++ b/meson.build
@@ -297,7 +297,7 @@ if get_option('png')
# that will bypass --wrap-mode and cause issues for distro packagers.
# See: https://mesonbuild.com/Reference-manual.html#dependency
if not png_dep.found()
- png_dep = dependency('', required: false, fallback: 'libpng')
+ png_dep = dependency('', required: false, fallback: ['libpng', 'png_dep'])
if png_dep.found()
enabled_loaders += 'png'
loaders_deps += png_dep
@@ -342,7 +342,7 @@ if get_option('jpeg') and not native_windows_loaders
# then use pkg-config, and if that fails, fall back to the
# wrap
if not enabled_loaders.contains('jpeg')
- jpeg_dep = dependency('libjpeg', required: false, fallback: 'libjpeg')
+ jpeg_dep = dependency('libjpeg', required: false, fallback: ['libjpeg', 'jpeg_dep'])
if jpeg_dep.found()
enabled_loaders += 'jpeg'