summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-08-22 12:46:21 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2018-08-22 12:48:56 +0100
commit7c783502ede10fd3fa329bc75118a3ffc015973b (patch)
tree149873227a4e3642af18e10242e135bc296f9915 /meson.build
parent53633afa85b79acc114fe0c3d5362d52ecb5050a (diff)
downloadgdk-pixbuf-7c783502ede10fd3fa329bc75118a3ffc015973b.tar.gz
Require Meson ≥ 0.46
Drop the conditional support on get_supported_link_arguments(), as there have been multiple stable releases of Meson with that method.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index d445ad16e..77bc94c4e 100644
--- a/meson.build
+++ b/meson.build
@@ -6,7 +6,7 @@ project('gdk-pixbuf', 'c',
'warning_level=1',
'c_std=c99',
],
- meson_version: '>= 0.45.0')
+ meson_version: '>= 0.46.0')
add_project_arguments([ '-D_POSIX_C_SOURCE=200809L', '-D_DEFAULT_SOURCE', '-D_XOPEN_SOURCE' ], language: 'c')
@@ -173,11 +173,7 @@ common_cflags += cc.get_supported_arguments(test_cflags)
if host_machine.system() == 'linux'
# Additional linker flags
test_ldflags = ['-Wl,-Bsymbolic', '-Wl,-z,relro', '-Wl,-z,now']
- if meson.version().version_compare('>= 0.46.0')
- common_ldflags += cc.get_supported_link_arguments(test_ldflags)
- else
- common_ldflags += test_ldflags
- endif
+ common_ldflags += cc.get_supported_link_arguments(test_ldflags)
gdk_pixbuf_conf.set('OS_LINUX', 1)
endif