summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-04-07 19:09:25 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2021-04-07 19:11:30 +0100
commit866670e30907eb534895da26626709ed5f2e419d (patch)
treeff40382fa391f7c0f3c2c5d41bffcb633d578305 /meson.build
parent6e8a9c608649db887705d3666cbd39e924319cb4 (diff)
downloadgdk-pixbuf-866670e30907eb534895da26626709ed5f2e419d.tar.gz
build: Port post-install script to Python
Avoid the whole shell/batch file shenanigans.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 5 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index 286f17c2d..b84d804c7 100644
--- a/meson.build
+++ b/meson.build
@@ -419,20 +419,11 @@ build_docs = get_option('gtk_doc') or get_option('docs')
subdir('docs')
if not meson.is_cross_build()
- # On Visual Studio, we don't normally have a shell interpreter, so use a .bat
- if cc.get_id() == 'msvc'
- meson.add_install_script('build-aux/post-install.bat',
- gdk_pixbuf_bindir,
- gdk_pixbuf_libdir,
- gdk_pixbuf_binary_version,
- )
- else
- meson.add_install_script('build-aux/post-install.sh',
- gdk_pixbuf_bindir,
- gdk_pixbuf_libdir,
- gdk_pixbuf_binary_version,
- )
- endif
+ meson.add_install_script('build-aux/post-install.py',
+ gdk_pixbuf_bindir,
+ gdk_pixbuf_libdir,
+ gdk_pixbuf_binary_version,
+ )
endif
if not meson.is_subproject()