summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorHesham Essam <hesham.essam.mail@gmail.com>2022-06-03 13:29:28 +0200
committerHesham Essam <hesham.essam.mail@gmail.com>2022-06-03 15:21:01 +0200
commit89fce0c2a1887b139b8a1bfbeb30c3d243c56f52 (patch)
tree743703713505ac95e2afe256a35de6410cb77203 /meson.build
parent5c516d02dc9a46b48cc4a9734f260615795891f0 (diff)
downloadgdk-pixbuf-89fce0c2a1887b139b8a1bfbeb30c3d243c56f52.tar.gz
Disable relocation when built as a static libary on Windows
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index ed82464e4..6b123847f 100644
--- a/meson.build
+++ b/meson.build
@@ -382,7 +382,7 @@ endif
# Determine whether we enable application bundle relocation support, and we use
# this always on Windows
if host_system == 'windows'
- relocatable = true
+ relocatable = (get_option('default_library') != 'static')
else
relocatable = get_option('relocatable')
endif
@@ -447,7 +447,7 @@ summary('MediaLib', use_medialib, section: 'Build')
summary('Introspection', build_gir, section: 'Build')
summary('Documentation', build_docs, section: 'Build')
summary('Manual pages', get_option('man'), section: 'Build')
-summary('Relocatable', get_option('relocatable'), section: 'Build')
+summary('Relocatable', relocatable, section: 'Build')
summary('Build tests', get_option('tests'), section: 'Build')
summary('Installed tests', get_option('installed_tests'), section: 'Build')