summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2018-10-08 17:18:56 +1100
committerMatthew Waters <matthew@centricular.com>2018-10-08 21:48:24 +1100
commit8c76a02bc6fffcb0fc57d855cec3afd694fbfe5c (patch)
tree45d2acb3d314ecb5885576a04559043675332ca5 /meson.build
parenta40611a88aab76de89f1defd68341169af992e3a (diff)
downloadgdk-pixbuf-8c76a02bc6fffcb0fc57d855cec3afd694fbfe5c.tar.gz
meson: add option for disabling GIO sniffing
Some linux-like platforms (e.g. Android) don't have a mime-info database readily available for use.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 43b11f61a..6b0ba49e2 100644
--- a/meson.build
+++ b/meson.build
@@ -189,11 +189,11 @@ gmodule_dep = dependency('gmodule-no-export-2.0')
gio_dep = dependency('gio-2.0')
# On non-Windows/macOS systems we always required shared-mime-info and GIO
-if host_system != 'windows' and host_system != 'darwin'
- shared_mime_dep = dependency('shared-mime-info')
+# shared_mime_dep = []
+shared_mime_dep = []
+if get_option('gio_sniffing') and host_system != 'windows' and host_system != 'darwin'
+ shared_mime_dep += dependency('shared-mime-info')
gdk_pixbuf_conf.set('GDK_PIXBUF_USE_GIO_MIME', 1)
-else
- shared_mime_dep = []
endif
# Check if medialib is available