summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-04-07 17:56:41 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2021-04-07 18:51:27 +0100
commita6175b65029c3ae01e9da8a1071863aff22aaf7b (patch)
tree66df2a8c937e228049f35a5b4ac69a6062493832 /meson.build
parent117cc8bececf6fa2e62ae2b953c5424f1d761508 (diff)
downloadgdk-pixbuf-a6175b65029c3ae01e9da8a1071863aff22aaf7b.tar.gz
Build PNG and JPEG loaders into gdk-pixbuf by default
GdkPixbuf without PNG and JPEG loaders is less than useful for loading assets in GTK (and anywhere else, really). We go to great lengths to ensure that both the PNG and JPEG loaders are built by default, to the point of including subprojects for libpng and libjpeg. Let's avoid any doubt, and ensure that those loaders are also included in the default shared library.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 43a88a6cf..286f17c2d 100644
--- a/meson.build
+++ b/meson.build
@@ -237,6 +237,10 @@ else
endif
gdk_pixbuf_conf.set('USE_GMODULE', build_modules)
+# We want these loaders to be built into gdk-pixbuf unless
+# the builtin_loaders option specifies otherwise
+default_builtin_loaders = [ 'png', 'jpeg' ]
+
# Check which loaders should be built into gdk-pixbuf
builtin_loaders = get_option('builtin_loaders').split(',')
@@ -245,6 +249,8 @@ builtin_loaders = get_option('builtin_loaders').split(',')
builtin_all_loaders = false
if builtin_loaders == [ 'all' ]
builtin_all_loaders = true
+elif builtin_loaders == [ 'default' ]
+ builtin_loaders = default_builtin_loaders
elif builtin_loaders == [ 'none' ]
builtin_loaders = []
endif