summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2020-02-20 12:22:09 +0800
committerEmmanuele Bassi <ebassi@gmail.com>2020-04-01 17:59:31 +0000
commitb22723c24a6e27ba90b170268cb5dd1744461ce0 (patch)
tree8335cd90103fa5d1f5b84e22a11a26287e309256 /meson.build
parent5a1e083ffb5c865daf6800023d70cf7852298db8 (diff)
downloadgdk-pixbuf-b22723c24a6e27ba90b170268cb5dd1744461ce0.tar.gz
Visual Studio builds: use -utf-8 if available
This avoids the build from erroring out due to warning/error C4819 (Unicode handling issue in the compiler), which is likely to occur on Chinese, Japanese and Korean locales
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 6aebaed1d..411af6ec3 100644
--- a/meson.build
+++ b/meson.build
@@ -119,8 +119,8 @@ common_ldflags = []
if cc.get_id() == 'msvc'
# For Visual Studio, just force-include msvc_reommended_pragmas.h
# so that we silence unwanted noise and track potential issues
- test_cflags = []
- add_project_arguments([ '-FImsvc_recommended_pragmas.h' ], language: 'c')
+ test_cflags = [ '-FImsvc_recommended_pragmas.h', '-utf-8' ]
+ add_project_arguments(cc.get_supported_arguments(test_cflags), language: 'c')
elif cc.get_id() == 'gcc' or cc.get_id() == 'clang'
test_cflags = [
'-Wpointer-arith',