summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-04-29 18:29:49 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2018-04-29 19:06:34 +0100
commitd08de097394f327e48544d40a8fb217a0d6424af (patch)
treeb3394c65564fd0a021bbcec0cf2ea5855a5a22d7 /meson.build
parent4c76635e1f19c6d1919d4ea94f6b00f97b996665 (diff)
downloadgdk-pixbuf-d08de097394f327e48544d40a8fb217a0d6424af.tar.gz
meson: Add post-install script
If we're installing gdk-pixbuf ourselves, we should generate the loaders cache file — unless DESTDIR is set or we're cross-compiling, in which case we assume that there's a packaging system hook in place to do this at the end of a full build.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 956b5f58d..40bbee079 100644
--- a/meson.build
+++ b/meson.build
@@ -418,3 +418,10 @@ subdir('thumbnailer')
# Documentation
subdir('docs/reference/gdk-pixbuf')
+
+if not meson.is_cross_build()
+ meson.add_install_script('build-aux/post-install.sh',
+ gdk_pixbuf_libdir,
+ gdk_pixbuf_binary_version,
+ )
+endif