summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBogDan Vatra <bogdan@kde.org>2021-03-01 10:30:56 +0200
committerBogDan Vatra <bogdan@kde.org>2021-03-22 11:26:57 +0200
commitdbd117b9272524d8f0ae42b2555872a160e5d291 (patch)
tree352053dc84eae46f67e032cfbd48146337561a89 /meson.build
parent51983512cdb863c49797ddc0a1eae71d5d8d369d (diff)
downloadgdk-pixbuf-dbd117b9272524d8f0ae42b2555872a160e5d291.tar.gz
Do not use shared-mime on Android
Similarly to what we do on Windows and macOS.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index f43d2334e..1acc43595 100644
--- a/meson.build
+++ b/meson.build
@@ -190,10 +190,10 @@ if host_machine.system() == 'darwin'
gdk_pixbuf_conf.set('OS_DARWIN', 1)
endif
-# On non-Windows/macOS systems we always required shared-mime-info and GIO
+# On non-Windows/macOS/android systems we always required shared-mime-info and GIO
# shared_mime_dep = []
shared_mime_dep = []
-if get_option('gio_sniffing') and host_system != 'windows' and host_system != 'darwin'
+if get_option('gio_sniffing') and host_system != 'windows' and host_system != 'darwin' and host_system != 'android'
shared_mime_dep += dependency('shared-mime-info')
gdk_pixbuf_conf.set('GDK_PIXBUF_USE_GIO_MIME', 1)
endif