summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <creiter@src.gnome.org>2018-11-16 16:55:49 +0100
committerChristoph Reiter <creiter@src.gnome.org>2018-11-16 16:56:14 +0100
commitdf43643be2c8668ba4c1f7bb702ee32a78dc096a (patch)
tree519ac59895aa8ece6f5110e18e000a18bb06935e /meson.build
parent1c91f930cf0ec6b538808bade74c9d290bd9f53b (diff)
downloadgdk-pixbuf-df43643be2c8668ba4c1f7bb702ee32a78dc096a.tar.gz
meson: use an autotools compatible compatibility_version/current_version on macOS
Use the same versioning scheme as libtool did with the autotools build. Otherwise switching gdk-pixbuf from meson to autotools makes all libraries linking to it fail since the version is too low.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 43b11f61a..96e72de84 100644
--- a/meson.build
+++ b/meson.build
@@ -42,6 +42,7 @@ revision = gdk_pixbuf_interface_age
libversion = '@0@.@1@.@2@'.format(soversion, current, revision)
age = gdk_pixbuf_binary_age - gdk_pixbuf_interface_age
current_minus_age = current - age
+darwin_versions = ['@0@'.format(current + 1), '@0@.@1@'.format(current + 1, gdk_pixbuf_interface_age)]
# Paths
gdk_pixbuf_prefix = get_option('prefix')
@@ -179,7 +180,7 @@ endif
if host_machine.system() == 'darwin'
# Maintain compatibility with autotools on macOS
- common_ldflags += [ '-compatibility_version 1', '-current_version 1.0', ]
+ common_ldflags += [ '-compatibility_version', darwin_versions[0], '-current_version', darwin_versions[1]]
gdk_pixbuf_conf.set('OS_DARWIN', 1)
endif