summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2013-06-07 14:56:12 -0400
committerMatthias Clasen <mclasen@redhat.com>2013-06-07 14:56:12 -0400
commit298eaf9ab48fc66bb3c143417cecd664ef4973fc (patch)
tree38acb38206f10179355f64b633a5750d3a753b06 /tests/Makefile.am
parent570a8f967cb7c315c4f9746a9094b4b1fc9c8611 (diff)
downloadgdk-pixbuf-298eaf9ab48fc66bb3c143417cecd664ef4973fc.tar.gz
Add an animation loading test
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 196ce79fb..639289e85 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -18,6 +18,7 @@ LDADDS = \
$(GDK_PIXBUF_DEP_LIBS)
noinst_PROGRAMS = \
+ animation \
pixbuf-read \
pixbuf-lowmem \
pixbuf-randomly-modified \
@@ -25,6 +26,7 @@ noinst_PROGRAMS = \
pixbuf-threads \
pixbuf-icon-serialize
+animation_LDADD = $(LDADDS)
pixbuf_read_LDADD = $(LDADDS)
pixbuf_lowmem_LDADD = $(LDADDS)
pixbuf_randomly_modified_LDADD = $(LDADDS)
@@ -40,7 +42,10 @@ insttest_PROGRAMS = \
pixbuf-threads \
$(NULL)
-insttest_DATA = test-image.png
+insttest_DATA = \
+ test-image.png \
+ test-animation.gif \
+ $(NULL)
testimagedir = $(insttestdir)/test-images
testimage_DATA = $(wildcard $(srcdir)/test-images/*)