summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 000000000..8f24c51eb
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,30 @@
+## Process this file with automake to produce Makefile.in
+
+SRC_SUBDIRS = glib gdk gtk
+SUBDIRS = $(SRC_SUBDIRS) docs
+
+EXTRA_DIST = gtk+.prj makecopyright TODO
+
+.PHONY: files populate checkin release
+
+files:
+ @files=`ls $(DISTFILES) 2> /dev/null `; for p in $$files; do \
+ echo $$p; \
+ done
+ @for subdir in $(SUBDIRS); do \
+ files=`cd $$subdir; $(MAKE) files | grep -v "make\[[1-9]\]"`; \
+ for file in $$files; do \
+ echo $$subdir/$$file; \
+ done; \
+ done
+
+populate:
+ @echo "populating project"
+ @files=`$(MAKE) files | grep -v "make\[[1-9]\]"`; prcs populate -d gtk+.prj $$files
+
+checkin: populate
+ @echo "checking in project"
+ @prcs checkin
+
+release:
+ $(MAKE) dist distdir=$(PACKAGE)`date +"%y%m%d"`