summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 4368c6bae..ab7ff1eee 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -1,6 +1,6 @@
# Resources contain PNG and BMP files, so we need these two loaders
# enabled in order to build them
-if enabled_loaders.contains('png') and enabled_loaders.contains('bmp')
+if enabled_loaders.contains('png')
# Resources; we cannot use gnome.compile_resources() here, because we need to
# override the environment in order to use the utilities we just built instead
# of the system ones
@@ -65,7 +65,6 @@ installed_tests = {
'pixbuf-construction': { 'suites': ['conform'], },
'animation': {
'suites': ['format'],
- 'skip': not enabled_loaders.contains('gif'),
},
'cve-2015-4491': {
'suites': ['security'],
@@ -107,11 +106,9 @@ installed_tests = {
'pixbuf-scale-two-step': { 'suites': ['ops'], },
'pixbuf-short-gif-write': {
'suites': ['format'],
- 'skip': not enabled_loaders.contains('gif'),
},
'pixbuf-gif-circular-table': {
'suites': ['format'],
- 'skip': not enabled_loaders.contains('gif'),
},
'pixbuf-save': { 'suites': ['io'] },
'pixbuf-readonly-to-mutable': { 'suites': ['conform'], },