summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 8475f5f5c..53ae0fb38 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -1,6 +1,10 @@
# Resources contain PNG and BMP files, so we need these two loaders
# enabled in order to build them
-if enabled_loaders.contains('png')
+# FIXME: On Windows glib-compile-resources will fail to execute
+# gdk-pixbuf-pixdata from build directory because it needs all DLL locations in
+# $PATH. Ideally we should use gnome.compile_resources() and let Meson deal with
+# this problem: See https://github.com/mesonbuild/meson/issues/8266.
+if enabled_loaders.contains('png') and host_system != 'windows'
# Resources; we cannot use gnome.compile_resources() here, because we need to
# override the environment in order to use the utilities we just built instead
# of the system ones