summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGeorge Lebl <jirka@5z.com>2002-04-23 21:58:56 +0000
committerGeorge Lebl <jirka@src.gnome.org>2002-04-23 21:58:56 +0000
commit3ced2f5772550e269fe39796e525f3b3f93afcb5 (patch)
treeb60daa76e7ff453f3fe3ffb280ace2515c759e38 /Makefile.am
parentbe888d777407106ef67c5da753d696701bcb199d (diff)
downloadgdm-3ced2f5772550e269fe39796e525f3b3f93afcb5.tar.gz
Make the gdmsetup proggie the default configurator and stop
Tue Apr 23 15:07:17 2002 George Lebl <jirka@5z.com> * Makefile.am, gdmconfig, gdmsetup-serurity.in, gdmsetup-pam, daemon/gdm.h, config/gdm.conf.in, gui/Makefile.am, gui/gdmsetup.desktop.in: Make the gdmsetup proggie the default configurator and stop building/installing gdmconfig which wasn't working to begin with. * gui/gdmchooser.(c|glade): redo the glade file for gdmchooser to be a dialog and also start using glade-helper * gui/gdmlogin.c: some gdmwm related fixes * gui/greeter/greeter.c, gui/greeter/greeter_action_language.c, gui/greeter/greeter_session.c, gui/greeter/greeter_system.c: Add Xinerama support, init the gdmwm so that we actually do have focus management, do all the cool gdmwm type stuff with all the dialogs/windows. Add all the warnings that gdmlogin can give. Damn this still needs a LOT of love before it's a viable replacement of gdmlogin.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index c0f8ec42..6a048f71 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,23 +6,23 @@ EXTRA_DIST = \
README.install \
gdm.spec \
gdm.spec.in \
- gdmconfig-pam \
- gdmconfig-security.in \
+ gdmsetup-pam \
+ gdmsetup-security.in \
intltool-extract.in \
intltool-merge.in \
intltool-update.in \
gdm-restart.in \
gdm-safe-restart.in
-sbin_SCRIPTS = gdm-restart gdm-safe-restart
+sbin_SCRIPTS = gdm-restart gdm-safe-restart gdmconfig
-install-data-local: gdmconfig-security
+install-data-local: gdmsetup-security
if CONSOLE_HELPER
- $(INSTALL_DATA) -D $(srcdir)/gdmconfig-pam $(DESTDIR)$(PAM_PREFIX)/pam.d/gdmconfig
- $(INSTALL_DATA) -D gdmconfig-security $(DESTDIR)$(PAM_PREFIX)/security/console.apps/gdmconfig
+ $(INSTALL_DATA) -D $(srcdir)/gdmsetup-pam $(DESTDIR)$(PAM_PREFIX)/pam.d/gdmsetup
+ $(INSTALL_DATA) -D gdmsetup-security $(DESTDIR)$(PAM_PREFIX)/security/console.apps/gdmsetup
$(INSTALL_DATA) -m 755 -d $(sbindir)
- mv -f $(bindir)/gdmconfig $(sbindir)
- $(LN_S) @CONSOLE_HELPER@ $(bindir)/gdmconfig
+ mv -f $(bindir)/gdmsetup $(sbindir)
+ $(LN_S) @CONSOLE_HELPER@ $(bindir)/gdmsetup
endif
DISTCLEANFILES = \