summaryrefslogtreecommitdiff
path: root/config/Makefile.am
diff options
context:
space:
mode:
authorBrian Cameron <brian.cameron@sun.com>2005-12-21 01:38:15 +0000
committerBrian Cameron <bcameron@src.gnome.org>2005-12-21 01:38:15 +0000
commit11c28082c288b2a0aad2ef182ee738965b93ed08 (patch)
tree2d39d8bea2b552fe4db17e1fa66573d333f54d3a /config/Makefile.am
parent2cfd51d25331c7d4cd4413a1d2616c3574ef31c5 (diff)
downloadgdm-11c28082c288b2a0aad2ef182ee738965b93ed08.tar.gz
Patch by Padraig O'Briain <Padraig.OBriain@sun.com>, modified by myself so
2005-12-21 Brian Cameron <brian.cameron@sun.com> Patch by Padraig O'Briain <Padraig.OBriain@sun.com>, modified by myself so it also works with gdmlogin and not just gdmgreeter. Also I integrated his gdmprefetch.c utility into the configure/Makefile system with the --with-prefetch option. * configure.ac: Now support --with-prefetch * daemon/gdm.h, daemon/gdmconfig.c, config/gdm.conf.in: Support new PostDisplayProgram key. * gui/gdmcommon.[ch], gui/gdmlogin.c, gui/greeter/greeter.c: Now support new PostDisplayProgram key. * docs/C/gdm.xml: Add docs for new key. * utils/Makefile.am, utils/gdmprefetch.c: Add new gdmprefetch utility. * config/Makefile.am: Now install gdm.conf file with 444 permissions and always write over the installed gdm.conf after first moving aside the user's gdm.conf file if necessary.
Diffstat (limited to 'config/Makefile.am')
-rw-r--r--config/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/config/Makefile.am b/config/Makefile.am
index df0fe549..aef9238f 100644
--- a/config/Makefile.am
+++ b/config/Makefile.am
@@ -80,13 +80,12 @@ install-data-hook: gdm.conf Xsession gnome.desktop default.desktop CDE.desktop I
else \
cp -f $(DESTDIR)$(gdmconfdir)/gdm.conf $(DESTDIR)$(gdmconfdir)/gdm.conf.org; \
fi; \
- $(INSTALL_DATA) gdm.conf $(DESTDIR)$(gdmconfdir)/gdm.conf; \
- fi
- if test '!' -f $(DESTDIR)$(gdmconfdir)/gdm.conf; then \
- $(INSTALL_DATA) gdm.conf $(DESTDIR)$(gdmconfdir)/gdm.conf; \
fi
+ $(INSTALL_DATA) gdm.conf $(DESTDIR)$(gdmconfdir)/gdm.conf
+ chmod 444 $(DESTDIR)$(gdmconfdir)/gdm.conf
if test '!' -f $(DESTDIR)$(gdmconfdir)/gdm.conf-custom; then \
$(INSTALL_DATA) gdm.conf-custom $(DESTDIR)$(gdmconfdir)/gdm.conf-custom; \
+ chmod 644 $(DESTDIR)$(gdmconfdir)/gdm.conf-custom; \
fi
$(INSTALL_DATA) gdm.conf $(DESTDIR)$(gdmconfdir)/factory-gdm.conf