summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Cameron <brian.cameron@sun.com>2007-04-13 05:33:41 +0000
committerBrian Cameron <bcameron@src.gnome.org>2007-04-13 05:33:41 +0000
commit146af696daacdea7823e273964b0ad8e8d73ee86 (patch)
treece395dc31a0fcb6359f20d3a296be450d4b4ab3d /configure.ac
parentf3c47295d959f4ff0d506d08ba27b052aaee921e (diff)
downloadgdm-146af696daacdea7823e273964b0ad8e8d73ee86.tar.gz
Set LogDir by default to /var/log/gdm and add configure --with-log-dir
2007-04-13 Brian Cameron <brian.cameron@sun.com> * configure.ac, config/Makefile.am: Set LogDir by default to /var/log/gdm and add configure --with-log-dir option so this can be easily configured. * gui/modules/AccessDwellMouseEvents.in, gui/modules/AccessKeyMouseEvents.in: Improve comments and make GOK key binding a bit less painful to enter. svn path=/trunk/; revision=4829
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d94b84f3..93b1d5c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -835,9 +835,17 @@ AC_SUBST(EXTRA_SETUP_LIBS)
#
AC_SUBST(authdir, ${localstatedir}/gdm)
AC_SUBST(gdmlocaledir, ${gdmconfdir})
-AC_SUBST(logdir, ${localstatedir}/log/gdm)
AC_SUBST(pixmapdir, ${datadir}/pixmaps)
+AC_ARG_WITH(log-dir, [ --with-log-dir=<file> log dir])
+
+if ! test -z "$with_log_dir"; then
+ GDM_LOG_DIR=$with_log_dir
+else
+ GDM_LOG_DIR=/var/log/gdm
+fi
+AC_SUBST(logdir, $GDM_LOG_DIR)
+
withval=""
AC_ARG_WITH(at-bindir,
[ --with-at-bindir=<PATH> PATH to Accessible Technology programs [default=BINDIR]],)