summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Cameron <brian.cameron@sun.com>2006-12-29 08:41:09 +0000
committerBrian Cameron <bcameron@src.gnome.org>2006-12-29 08:41:09 +0000
commit4d102692e81bfff9f2950136b2abe4cd6724d96b (patch)
tree3217768b5cfb57f9265e1e3102dbc1c9625d501b /configure.ac
parent9bfc7c4aafc4716b659e6ef0690d20e1d10afa56 (diff)
downloadgdm-4d102692e81bfff9f2950136b2abe4cd6724d96b.tar.gz
Now GDM will recognize when the system language has changed and when new
2006-12-29 Brian Cameron <brian.cameron@sun.com> * configure.ac, daemon/Makefile.am, daemon/misc.[ch], daemon/slave.c, daemon/verify-pam.c: Now GDM will recognize when the system language has changed and when new GUI's are displayed they will be in the new system language without neeting to restart GDM. By default the /var/sysconfig/i18n file is assumed to have the language defined in LANG=foo format. The --with-lang-file configure option may be needed to specify a different system language configuration file. On Solaris it would be /etc/default/init, for example. Note the change to verify-pam is done to flush the hash table of pam messages to useful translations. This change implements enhancement request #384603. Patch by Ray Strode <rstrode@redhat.com> and Takao Fujiwara <Takao.Fujiwara@sun.com>.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 34282fac..09b2250b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -116,6 +116,21 @@ else
fi
AC_SUBST(PAM_PREFIX)
+dnl
+dnl file that sets LANG
+dnl
+withval=""
+AC_ARG_WITH(lang-file,
+ [ --with-lang-file=<filename> file containing default language setting],[
+if test x$withval != x; then
+AC_MSG_RESULT("System locale will be looked for in file ${withval}.")
+fi])
+if test x$withval != x; then
+ LANG_CONFIG_FILE="$withval"
+else
+ LANG_CONFIG_FILE='${sysconfdir}/sysconfig/i18n'
+fi
+AC_SUBST(LANG_CONFIG_FILE)
AC_PATH_PROG(CONSOLE_HELPER,consolehelper,no)
if test "x$CONSOLE_HELPER" = "xno" ; then