summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2015-06-12 13:48:52 -0400
committerRay Strode <rstrode@redhat.com>2015-06-12 14:29:04 -0400
commit9be58c9ec9a3a411492a5182ac4b0d51fdc3a323 (patch)
tree2e332c83a5fa68e8c7114defb6603fb65045f86e /configure.ac
parent1ac67f522f5690c27023d98096ca817f12f7eb88 (diff)
downloadgdm-9be58c9ec9a3a411492a5182ac4b0d51fdc3a323.tar.gz
require logind support
Now that consolekit support is gone, this commit drops all the conditionalizing of logind support. https://bugzilla.gnome.org/show_bug.cgi?id=743940
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 1 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 80d92aac..7d65478f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -245,10 +245,6 @@ AC_ARG_WITH(tcp-wrappers,
with_tcp_wrappers=auto)
-AC_ARG_WITH(systemd,
- AS_HELP_STRING([--with-systemd],
- [Add systemd support @<:@default=auto@:>@]),
- [with_systemd=$withval], [with_systemd=auto])
AC_ARG_WITH([systemdsystemunitdir],
AS_HELP_STRING([--with-systemdsystemunitdir=DIR],
[Directory for systemd service files]),
@@ -878,26 +874,8 @@ dnl - Check for systemd support
dnl ---------------------------------------------------------------------------
PKG_CHECK_MODULES(SYSTEMD,
- [libsystemd-login >= 186 libsystemd-daemon],
- [have_systemd=yes], [have_systemd=no])
+ [libsystemd-login >= 186 libsystemd-daemon])
-if test "x$with_systemd" = "xauto" ; then
- if test x$have_systemd = xno ; then
- use_systemd=no
- else
- use_systemd=yes
- fi
-else
- use_systemd="$with_systemd"
-fi
-
-if test "x$use_systemd" != "xno" ; then
- if test "x$have_systemd" = "xno"; then
- AC_MSG_ERROR([Systemd support explicitly required, but systemd not found])
- fi
-
- AC_DEFINE(WITH_SYSTEMD, 1, [Define to enable systemd support])
-fi
AC_SUBST(SYSTEMD_CFLAGS)
AC_SUBST(SYSTEMD_LIBS)
@@ -1615,7 +1593,6 @@ echo \
" Xinerama support: ${XINERAMA_SUPPORT}
XDMCP support: ${XDMCP_SUPPORT}
SELinux support: ${use_selinux}
- systemd support: ${use_systemd}
systemd unit dir: ${with_systemdsystemunitdir}
plymouth support: ${use_plymouth}
wayland support: ${use_wayland}