summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Jon McCann <mccann@jhu.edu>2007-03-26 19:22:05 +0000
committerWilliam Jon McCann <mccann@src.gnome.org>2007-03-26 19:22:05 +0000
commitcec2a7f5ef8858aab7d4f6ecaeccf9e1a66cb1c3 (patch)
treee2f6f7f48f46bca0ea9676061f154e56f34f41f3 /configure.ac
parentf4ef945ec319c2b5838adf53c9bf9671892a9164 (diff)
downloadgdm-cec2a7f5ef8858aab7d4f6ecaeccf9e1a66cb1c3.tar.gz
Remove the PidFile configuration option. Fixes #162849
2007-03-26 William Jon McCann <mccann@jhu.edu> * config/gdm.conf.in: * configure.ac: * daemon/gdm-daemon-config-entries.h: * daemon/gdm-daemon-config-keys.h: * daemon/gdm-daemon-config.c: (gdm_daemon_config_to_string), (check_servauthdir), (handle_no_displays), (gdm_daemon_change_user), (gdm_daemon_check_permissions): * daemon/gdm.c: (gdm_daemonify), (gdm_final_cleanup), (main): * gui/gdmXnestchooser.c: (main): * gui/gdmcomm.c: (gdmcomm_check): * gui/gdmlogin.c: (gdm_read_config): * gui/greeter/greeter.c: (gdm_read_config): Remove the PidFile configuration option. Fixes #162849 svn path=/trunk/; revision=4714
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9c2cd809..da9376d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1116,8 +1116,24 @@ if test "x$USER_POST_PATH" != "x"; then
GDM_USER_PATH="$GDM_USER_PATH:$USER_POST_PATH"
fi
+dnl ---------------------------------------------------------------------------
+dnl - PID file
+dnl ---------------------------------------------------------------------------
-# Turn on the additional warnings last, so they don't affect other tests.
+AC_ARG_WITH(pid-file, [ --with-pid-file=<file> pid file])
+
+if ! test -z "$with_pid_file"; then
+ GDM_PID_FILE=$with_pid_file
+else
+ GDM_PID_FILE=${LOCALSTATEDIR}/run/gdm.pid
+fi
+
+AC_SUBST(GDM_PID_FILE)
+AC_DEFINE_UNQUOTED(GDM_PID_FILE, "$GDM_PID_FILE", [pid file])
+
+dnl ---------------------------------------------------------------------------
+dnl - Additional warnings
+dnl ---------------------------------------------------------------------------
AC_ARG_ENABLE(more-warnings,
AC_HELP_STRING([--enable-more-warnings], [Maximum compiler warnings]),