summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2014-04-01 13:11:57 -0400
committerRay Strode <rstrode@redhat.com>2014-04-10 13:05:01 -0400
commite546e4dc6649a4fdf9065322420a28fa7e666782 (patch)
tree4cf41e113a9ba51d0ac0cc2b629f837ad2a67ce2 /configure.ac
parent257132e3bfb339b19ab35f9689748cfc3d3a3f93 (diff)
downloadgdm-e546e4dc6649a4fdf9065322420a28fa7e666782.tar.gz
worker: get PATH from parent instead of #define
If no PATH is set, then the session worker tries to set one up, based on guess. This commit changes GDM to just use the PATH given to GDM itself, rather than guessing (and getting it wrong). https://bugzilla.gnome.org/show_bug.cgi?id=727980
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index f66fdd9d..10bb8384 100644
--- a/configure.ac
+++ b/configure.ac
@@ -274,23 +274,6 @@ AC_ARG_WITH(at-spi-registryd-directory,
AT_SPI_REGISTRYD_DIR=$with_at_spi_registryd_directory
AC_SUBST(AT_SPI_REGISTRYD_DIR)
-# Allow configuration of default PATH
-#
-withval=""
-AC_ARG_WITH(default-path,
- AS_HELP_STRING([--with-default-path=<PATH>],
- [PATH GDM will use as the user's default PATH]),
- [if test x$withval != x; then
- AC_MSG_RESULT("PATH ${withval} will be the default PATH.")
- fi])
-
-if test x$withval != x; then
- GDM_SESSION_DEFAULT_PATH="$withval"
-else
- GDM_SESSION_DEFAULT_PATH="/usr/local/bin:/usr/bin:/bin"
-fi
-AC_SUBST(GDM_SESSION_DEFAULT_PATH)
-
dnl
dnl file that sets LANG
dnl