summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2015-02-17 13:33:23 -0500
committerRay Strode <rstrode@redhat.com>2015-02-18 17:34:14 -0500
commita3c197e453911891ffb8243e5525ab8863e074f1 (patch)
tree805eff7d162534837d47f5dd24e72579f63f8fa1 /daemon/Makefile.am
parent1a13e58abe70f70ba35bf297af12383ca70949c5 (diff)
downloadgdm-a3c197e453911891ffb8243e5525ab8863e074f1.tar.gz
daemon: add wrapper for launching wayland session
This wrapper makes sure the wayland session is registered with the display manager, and that the wayland session gets a dbus-daemon that's automatically cleaned up when the session goes away. https://bugzilla.gnome.org/show_bug.cgi?id=744764
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index fd7ac4a3..1f2feb49 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -111,6 +111,7 @@ test_session_client_LDADD = \
libexec_PROGRAMS = \
gdm-session-worker \
+ gdm-wayland-session \
$(NULL)
gdm_session_worker_SOURCES = \
@@ -141,6 +142,19 @@ nodist_gdm_session_worker_SOURCES = \
gdm-session-enum-types.h \
$(NULL)
+gdm_wayland_session_LDADD = \
+ $(top_builddir)/common/libgdmcommon.la \
+ $(GTK_LIBS) \
+ $(COMMON_LIBS) \
+ $(SYSTEMD_LIBS) \
+ $(NULL)
+
+gdm_wayland_session_SOURCES = \
+ gdm-manager-glue.h \
+ gdm-manager-glue.c \
+ gdm-wayland-session.c \
+ $(NULL)
+
if HAVE_LIBAUDIT
gdm_session_worker_SOURCES += gdm-session-linux-auditor.h \
gdm-session-linux-auditor.c