summaryrefslogtreecommitdiff
path: root/daemon/meson.build
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2020-12-10 15:14:20 -0500
committerRay Strode <rstrode@redhat.com>2020-12-11 14:50:24 -0500
commitdcdbaaa04012541ad2813cf83559d91d52f208b9 (patch)
tree30e9e9f3e35dbcb64ddee5ae98057d2a1322797b /daemon/meson.build
parenta58aec716855c8b47c32008455f212ecbd85ef2f (diff)
downloadgdm-dcdbaaa04012541ad2813cf83559d91d52f208b9.tar.gz
session-worker: Don't switch back VTs until session is fully exitedwip/fix-autologin-unlock-race
There's a race condition on shutdown where the session worker is switching VTs back to the initial VT at the same time as the session exit is being processed. This means that manager may try to start a login screen (because of the VT switch) when autologin is enabled when there shouldn't be a login screen. This commit makes sure both the PostSession script, and session-exited signal emission are complete before initiating the VT switch back to the initial VT. https://gitlab.gnome.org/GNOME/gdm/-/issues/660
Diffstat (limited to 'daemon/meson.build')
-rw-r--r--daemon/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/daemon/meson.build b/daemon/meson.build
index 72c7c3c1..2e61b644 100644
--- a/daemon/meson.build
+++ b/daemon/meson.build
@@ -1,4 +1,10 @@
# D-Bus interfaces
+dbus_gen = gnome.gdbus_codegen('gdm-dbus-glue',
+ 'org.freedesktop.DBus.xml',
+ namespace: 'GdmDBus',
+ interface_prefix: 'org.freedesktop.DBus',
+ autocleanup: 'all',
+)
display_dbus_gen = gnome.gdbus_codegen('gdm-display-glue',
'gdm-display.xml',
namespace: 'GdmDBus',
@@ -87,6 +93,7 @@ gdm_session_worker_src = [
'gdm-session-worker-job.c',
'gdm-session-worker-common.c',
'gdm-dbus-util.c',
+ dbus_gen,
session_dbus_gen,
session_worker_dbus_gen,
gdm_session_enums,