summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2022-02-14 17:03:09 -0500
committerRay Strode <rstrode@redhat.com>2022-02-15 09:06:44 -0500
commitb2d6ccee16df921af515efd559dcf59d5b2d0d99 (patch)
tree17fd29e1fec56733f83df1cb9729c9a25cc2527c /data/meson.build
parent7661ffceaa8e0e19d129d5376546438af56f7750 (diff)
downloadgdm-b2d6ccee16df921af515efd559dcf59d5b2d0d99.tar.gz
data: Don't race with vendor nvidia driver at startup
The vendor nvidia driver has two modules loaded at startup. It's not uncommon for the second module to still be loading when GDM starts. Our udev rule relies on the second module to set up GDM's boot configuration. This commit adds some synchronization to stall GDM a bit if the vendor driver is still coming up. https://gitlab.gnome.org/GNOME/gdm/-/issues/763
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/data/meson.build b/data/meson.build
index 2dec4c23..8764abfe 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -149,6 +149,7 @@ gdm_rules = configure_file(
output: '@BASENAME@',
configuration: {
'libexecdir': gdm_prefix / get_option('libexecdir'),
+ 'bindir': gdm_prefix / get_option('bindir'),
},
install_dir: udev_dir,
)
@@ -185,6 +186,14 @@ configure_file(
format: 'cmake'
)
+configure_file(
+ input: 'gdm-waiting-on-udev.path.in',
+ output: '@BASENAME@',
+ configuration: service_config,
+ install_dir: systemd_systemunitdir,
+ format: 'cmake'
+)
+
gdm_gnome_session_wanted_targets = []
foreach component: gdm_gnome_user_session_wanted_components
gdm_gnome_session_wanted_targets += 'Wants=@0@.target'.format(component)