summaryrefslogtreecommitdiff
path: root/gui/simple-greeter/libnotificationarea/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2010-01-26 14:18:36 +0000
committerRichard Hughes <richard@hughsie.com>2010-01-26 14:18:36 +0000
commit8e64ca9b78451b10096180a12b4b7d632915b85a (patch)
tree01eefe99fa0b0031a08a8df97c67335aaed73409 /gui/simple-greeter/libnotificationarea/Makefile.am
parentd5ce446cd5a4317a21844dd7e44c380ea2282c5f (diff)
downloadgdm-8e64ca9b78451b10096180a12b4b7d632915b85a.tar.gz
Fix compile when using a linker that defaults to --no-as-needed
Diffstat (limited to 'gui/simple-greeter/libnotificationarea/Makefile.am')
-rw-r--r--gui/simple-greeter/libnotificationarea/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/gui/simple-greeter/libnotificationarea/Makefile.am b/gui/simple-greeter/libnotificationarea/Makefile.am
index 4009aaf5..7df07505 100644
--- a/gui/simple-greeter/libnotificationarea/Makefile.am
+++ b/gui/simple-greeter/libnotificationarea/Makefile.am
@@ -11,6 +11,7 @@ INCLUDES = \
-DPIXMAPDIR=\"$(pixmapdir)\" \
-DSBINDIR=\"$(sbindir)\" \
$(GTK_CFLAGS) \
+ $(XLIB_CFLAGS) \
$(NULL)
noinst_LTLIBRARIES = \
@@ -39,6 +40,7 @@ libnotificationarea_la_SOURCES = \
libnotificationarea_la_LIBADD = \
$(GTK_LIBS) \
+ $(XLIB_LIBS) \
$(NULL)
libnotificationarea_la_LDFLAGS = \
@@ -65,4 +67,5 @@ testtray_SOURCES = \
testtray_LDADD = \
libnotificationarea.la \
$(GREETER_LIBS) \
+ $(XLIB_LIBS) \
$(NULL)